PT-2020-16366

CVE-2020-26238

·

Published

2020-11-24

·

Updated

2021-03-24

Description by

CVSS 3.1
7.9
High
MetricsAV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions cron-utils versions prior to 9.1.3
Description A template injection vulnerability is present in cron-utils, enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. This issue affects only projects using the @Cron annotation to validate untrusted Cron expressions.
Recommendations For versions prior to 9.1.3, upgrade to version 9.1.3 to resolve the issue. As a temporary workaround, consider avoiding the use of the @Cron annotation to validate untrusted Cron expressions until the patch is applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-PFJ3-56HM-JWQ5
Found an issue in the description? Have something to add? Feel free to write us 👾