PT-2020-16524
CVE-2020-26876
·
Published
2020-10-07
·
Updated
2021-07-21
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
wp-courses plugin versions prior to 2.0.28
Description
The issue allows remote attackers to bypass the intended payment step for course videos and materials. This is achieved by utilizing the
/wp-json REST API, with show in rest enabled for custom post types, such as /wp-json/wp/v2/course and /wp-json/wp/v2/lesson. The issue has been exploited in the wild.Recommendations
For wp-courses plugin versions prior to 2.0.28, update to version 2.0.28 or later to resolve the issue. As a temporary workaround, consider disabling the REST API endpoints
/wp-json/wp/v2/course and /wp-json/wp/v2/lesson until the update is applied.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾