PT-2020-16939

CVE-2020-28184

·

Published

2020-12-24

·

Updated

2020-12-28

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions TerraMaster TOS versions 4.2.06 and earlier
Description The issue allows remote authenticated users to inject arbitrary web script or HTML via the mod parameter to "/module/index.php" API endpoint. This enables attackers to execute malicious scripts on the victim's browser, potentially leading to unauthorized actions or data theft.
Recommendations For TerraMaster TOS versions 4.2.06 and earlier, update to a version later than 4.2.06 to resolve the issue. As a temporary workaround, consider restricting access to the "/module/index.php" API endpoint or sanitizing the mod parameter to prevent malicious input.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾