PT-2020-17355
CVE-2020-35589
·
Published
2020-12-21
·
Updated
2020-12-22
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
limit-login-attempts-reloaded plugin versions prior to 2.17.4 for WordPress
Description
The issue allows a malicious user to cause an administrator user to supply dangerous content to the vulnerable page, which is then reflected back to the user and executed by the web browser. The most common mechanism for delivering malicious content is to include it as a parameter in a URL that is posted publicly or e-mailed directly to victims. This occurs through the "wp-admin/options-general.php?page=limit-login-attempts&tab=" API endpoint.
Recommendations
For limit-login-attempts-reloaded plugin versions prior to 2.17.4, update to version 2.17.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the "wp-admin/options-general.php?page=limit-login-attempts&tab=" endpoint until a patch is applied. Avoid using this endpoint with untrusted input to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾