PT-2020-17405
CVE-2020-35716
·
Published
2020-12-26
·
Updated
2020-12-28
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Belkin LINKSYS RE6500 versions prior to 1.0.012.001
Description
The issue allows remote attackers to cause a persistent denial of service, resulting in a segmentation fault. This can be achieved by sending a long
langSelectionOnly parameter via the "/goform/langSwitch" API endpoint.Recommendations
For versions prior to 1.0.012.001, update to version 1.0.012.001 or later to resolve the issue. As a temporary workaround, consider restricting access to the "/goform/langSwitch" API endpoint to minimize the risk of exploitation. Avoid using the
langSelectionOnly parameter in the affected API endpoint until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾