PT-2020-17820

CVE-2020-3979

·

Published

2020-09-18

·

Updated

2021-07-21

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions InstallBuilder for Qt Windows versions prior to 20.7.0
Description The issue allows an attacker to potentially execute code with the security scope of the installer by planting a malicious library in a predictable location where the installer looks for plugins at initialization time. This location is writable by non-admin users, and while the plugins are not required, they are loaded if present.
Recommendations For versions prior to 20.7.0, update to version 20.7.0 or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾