PT-2020-18374

CVE-2020-5284

·

Published

2020-03-30

·

Updated

2020-04-01

Description by

CVSS 2.0
5.0
Medium
MetricsAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Next.js versions prior to 9.3.2
Description The issue allows attackers to craft special requests to access files in the dist directory (.next) due to a directory traversal vulnerability. This vulnerability does not affect files outside of the dist directory (.next). In general, the dist directory only holds build assets unless the application intentionally stores other assets under this directory.
Recommendations For Next.js versions prior to 9.3.2, upgrade to version 9.3.2 to resolve the issue. As a temporary workaround, consider restricting access to the dist directory (.next) to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-FQ77-7P7R-83RJ
Found an issue in the description? Have something to add? Feel free to write us 👾