PT-2020-18765
CVE-2020-5864
·
Published
2020-04-23
·
Updated
2020-04-30
Description by
CVSS 3.1
7.4
HighMetricsAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions
NGINX Controller versions prior to 3.2.0
Description
The issue concerns communication between NGINX Controller and NGINX Plus instances, where TLS verification is skipped by default. This affects versions of NGINX Controller prior to 3.2.0.
Recommendations
For versions prior to 3.2.0, update to version 3.2.0 or later to ensure TLS verification is properly enforced. As a temporary workaround, consider configuring NGINX Controller to enable TLS verification manually until a patch is applied. Restrict access to NGINX Plus instances to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾