PT-2020-1936
CVE-2020-3770
·
Published
2020-03-18
·
Updated
2021-09-08
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Adobe Photoshop CC 2019 versions 20.0.8 and earlier
Adobe Photoshop 2020 versions 21.1 and earlier
Description
The issue is related to a buffer error in the graphic editor, which could allow a remote attacker to execute arbitrary code on the target system by opening a malicious file. Successful exploitation of this buffer error vulnerability could lead to arbitrary code execution.
Recommendations
For Adobe Photoshop CC 2019 versions 20.0.8 and earlier, update to a version later than 20.0.8 to resolve the issue.
For Adobe Photoshop 2020 versions 21.1 and earlier, update to a version later than 21.1 to resolve the issue.
As a temporary workaround, consider avoiding the opening of suspicious or untrusted files with Adobe Photoshop until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾