PT-2020-19701
CVE-2020-7676
·
Published
2020-06-08
·
Updated
2026-08-04
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
angular.js versions prior to 1.8.0
Description
The issue allows cross-site scripting due to the regex-based input HTML replacement potentially turning sanitized code into unsanitized code. This can occur when
<option> elements are wrapped in <select> elements, changing the parsing behavior and possibly leading to unsanitized code.Recommendations
For versions prior to 1.8.0, update to version 1.8.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of
<option> elements within <select> elements to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾