PT-2020-19777

CVE-2020-7765

·

Published

2020-11-16

·

Updated

2021-05-18

Description by

CVSS 3.1
5.6
Medium
MetricsAV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions @firebase/util versions prior to 0.3.4
Description This issue relates to the deepExtend function within the DeepCopy.ts file. Depending on user input, an attacker can overwrite and pollute the object prototype of a program.
Recommendations For versions prior to 0.3.4, update to version 0.3.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of the deepExtend function within the DeepCopy.ts file until a patch is applied. Avoid using user input that could potentially overwrite and pollute the object prototype of a program.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-FPM5-VV97-JFWG
SNYK-JS-FIREBASEUTIL-1038324
Found an issue in the description? Have something to add? Feel free to write us 👾