PT-2020-20060
CVE-2020-8252
·
Published
2020-01-24
·
Updated
2026-10-21
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
libuv versions prior to 10.22.1
libuv versions prior to 12.18.4
libuv versions prior to 14.9.0
Description
The issue arises from the incorrect determination of buffer size in the realpath implementation within libuv, which is used by Node.js. This can lead to a buffer overflow if the resolved path exceeds 256 bytes.
Recommendations
For versions prior to 10.22.1, update to version 10.22.1 or later to resolve the issue.
For versions prior to 12.18.4, update to version 12.18.4 or later to resolve the issue.
For versions prior to 14.9.0, update to version 14.9.0 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾