PT-2020-20123

CVE-2020-8417

·

Published

2020-01-28

·

Updated

2020-02-10

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Code Snippets plugin versions prior to 2.14.0
Description The issue allows for CSRF due to the lack of a Referer check on the import menu. This can potentially lead to WordPress site takeover. There are reports of this issue being exploited in real-world attacks, allowing for escalation from CSRF to RCE.
Recommendations For versions prior to 2.14.0, update to version 2.14.0 or later to resolve the issue. As a temporary workaround, consider implementing additional security measures to restrict access to the import menu and validate Referer headers to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾