PT-2020-21012

Published

2020-09-11

·

Updated

2020-09-11

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions swagger-ui versions prior to 3.20.9
Description The issue is related to Cross-Site Scripting (XSS) due to the failure to sanitize URLs used in the OAuth auth flow, which may allow attackers to execute arbitrary JavaScript.
Recommendations Upgrade to version 3.20.9 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-4F9M-PXWH-68HG
Found an issue in the description? Have something to add? Feel free to write us 👾