PT-2020-21070
Published
2020-09-03
·
Updated
2020-09-03
Description by
CVSS 3.1
5.9
MediumMetricsAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
simple-crypto-js versions prior to 2.3.0
Description
The issue concerns the use of AES-CBC with PKCS#7 padding, which is susceptible to padding oracle attacks. This could potentially allow attackers to break the encryption and access sensitive data.
Recommendations
For simple-crypto-js versions prior to 2.3.0, upgrade to version 2.3.0 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾