PT-2020-21198

Published

2020-09-04

·

Updated

2020-09-04

Description by

CVSS 3.1
7.2
High
MetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions strapi versions prior to 3.0.0-beta.17.8
Description The issue is related to Command Injection due to the failure to sanitize plugin names in the "/admin/plugins/install/" route. This may allow an authenticated attacker with admin privileges to run arbitrary commands on the server.
Recommendations Upgrade to version 3.0.0-beta.17.8 or later. As a temporary workaround, consider restricting access to the "/admin/plugins/install/" route to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-9P2W-RMX4-9MW7
Found an issue in the description? Have something to add? Feel free to write us 👾