PT-2020-21436

Published

2020-04-16

·

Updated

2020-04-16

Description by

CVSS 3.1
6.1
Medium
MetricsAV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions https-proxy-agent versions prior to 2.2.3
Description The issue allows an attacker with access to the proxy server to intercept unencrypted communications, which may include sensitive information such as credentials, by failing to enforce TLS on the socket if the proxy server responds to the request with a HTTP status different than 200.
Recommendations Upgrade to version 2.2.3 or 3.0.0.
Exploitability
Fix
Vendors
Affected products
Related identifiers
GHSA-PC5P-H8PF-MVWP
Found an issue in the description? Have something to add? Feel free to write us 👾