PT-2020-2561
CVE-2020-11041
·
Published
2020-04-09
·
Updated
2024-06-15
Description by
CVSS 2.0
4.0
MediumMetricsAV:N/AC:L/Au:S/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
FreeRDP versions less than or equal to 2.0.0
Description
The issue arises from an outside controlled array index being used unchecked for data used as configuration for the sound backend, such as alsa, oss, or pulse. This could lead to a crash of the client instance, resulting in no or distorted sound, or a session disconnect.
Recommendations
For versions less than or equal to 2.0.0, update to version 2.1.0 to resolve the issue.
As a temporary workaround for users who cannot upgrade to the patched version, consider disabling sound for the session to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾