PT-2020-2986

CVE-2020-14402

·

Published

2020-06-17

·

Updated

2022-03-09

Description by

CVSS 2.0
5.5
Medium
MetricsAV:N/AC:L/Au:S/C:P/I:N/A:P
Name of the Vulnerable Software and Affected Versions LibVNCServer versions prior to 0.9.13
Description The issue is caused by an out-of-bounds access in the libvncserver/corre.c component of the LibVNCServer library. This can be exploited by a remote attacker to impact the confidentiality, integrity, and availability of protected information.
Recommendations For versions prior to 0.9.13, update to version 0.9.13 or later to resolve the issue. As a temporary workaround, consider restricting access to the libvncserver/corre.c component until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2020-2671
ALT-PU-2020-2694
DLA-2264-1
DLA-2347-1
MGASA-2020-0280
MGASA-2020-0288
OPENSUSE-SU-2020:0988-1
OPENSUSE-SU-2020_0988-1
OPENSUSE-SU-2020:1025-1
OPENSUSE-SU-2020_1025-1
OPENSUSE-SU-2020:1056-1
OPENSUSE-SU-2020_1056-1
OPENSUSE-SU-2024:10598-1
SUSE-SU-2020:14424-1
SUSE-SU-2020:1922-1
SUSE-SU-2020:2167-1
USN-4434-1
USN-4573-1
Found an issue in the description? Have something to add? Feel free to write us 👾