PT-2020-3002
CVE-2020-15011
·
Published
2020-06-08
·
Updated
2021-12-01
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
GNU Mailman versions prior to 2.1.33
Description
The issue exists due to insufficient input validation in the Cgi/private.py private archive login page of the GNU Mailman mailing list management system. This allows a remote attacker to inject arbitrary content using a specially crafted request.
Recommendations
For GNU Mailman versions prior to 2.1.33, update to version 2.1.33 or later to resolve the issue. As a temporary workaround, consider restricting access to the Cgi/private.py private archive login page to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾