PT-2020-3527

CVE-2020-14576

·

Published

2020-07-14

·

Updated

2022-07-28

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:L/Au:S/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions MySQL Server versions 5.7.30 and prior MySQL Server versions 8.0.20 and prior
Description The vulnerability is related to insufficient input validation in the MySQL Server component, specifically in the User-Defined Functions (UDF) system. This issue can be exploited by a remote attacker to cause a denial of service, resulting in a hang or frequently repeatable crash of the MySQL Server. The vulnerability can be exploited via multiple protocols, allowing an attacker with network access to compromise the server.
Recommendations For MySQL Server versions 5.7.30 and prior, update to a version later than 5.7.30 to resolve the issue. For MySQL Server versions 8.0.20 and prior, update to a version later than 8.0.20 to resolve the issue. As a temporary workaround, consider restricting network access to the MySQL Server to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALSA-2020:3732
ALT-PU-2020-2640
ALT-PU-2021-2380
ALT-PU-2021-3668
CESA-2020_3732
RHSA-2020:3518
RHSA-2020:3732
RHSA-2020_3732
RHSA-2020:3755
RHSA-2020:3757
RLSA-2020:3732
USN-4441-1
USN-4441-2
Found an issue in the description? Have something to add? Feel free to write us 👾