PT-2020-3583
CVE-2020-14344
·
Published
2020-07-31
·
Updated
2026-05-07
Description by
CVSS 3.1
6.7
MediumMetricsAV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
libX11 versions prior to 1.6.10
Description
The issue is caused by an integer overflow in the libX11 library, which can lead to a heap-buffer overflow. This can potentially impact the confidentiality, integrity, and availability of protected information. The vulnerability is security-relevant when setuid programs call XIM client functions while running with elevated privileges.
Recommendations
For versions prior to 1.6.10, update to version 1.6.10 or later to resolve the issue. As a temporary workaround, consider restricting the use of setuid programs that call XIM client functions to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾