PT-2020-5016

CVE-2020-24435

·

Published

2020-11-03

·

Updated

2021-09-08

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Adobe Acrobat Reader DC versions 2020.012.20048 and earlier Adobe Acrobat Reader DC versions 2020.001.30005 and earlier Adobe Acrobat Reader DC versions 2017.011.30175 and earlier
Description A heap-based buffer overflow vulnerability exists in the submitForm function, potentially allowing arbitrary code execution in the context of the current user. This issue can be exploited by opening a crafted .pdf file in Acrobat Reader, requiring user interaction. The vulnerability may enable a remote attacker to execute arbitrary code in the context of the current user using a specially formed PDF file.
Recommendations For Adobe Acrobat Reader DC versions 2020.012.20048 and earlier, update to a version later than 2020.012.20048 to resolve the issue. For Adobe Acrobat Reader DC versions 2020.001.30005 and earlier, update to a version later than 2020.001.30005 to resolve the issue. For Adobe Acrobat Reader DC versions 2017.011.30175 and earlier, update to a version later than 2017.011.30175 to resolve the issue. As a temporary workaround, consider disabling the submitForm function until a patch is available. Avoid opening suspicious or untrusted .pdf files in Acrobat Reader to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾