PT-2020-5328
CVE-2020-25643
·
Published
2020-09-25
·
Updated
2026-10-19
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:M/Au:S/C:P/I:P/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.9-rc7
Description
A flaw in the HDLC PPP module of the Linux kernel causes memory corruption and a read overflow due to improper input validation in the
ppp cp parse cr function. This can lead to a system crash or denial of service, posing a threat to data confidentiality, integrity, and system availability. The vulnerability can be exploited by a remote attacker to cause a denial of service.Recommendations
For Linux kernel versions prior to 5.9-rc7, update to version 5.9-rc7 or later to resolve the issue. As a temporary workaround, consider restricting access to the HDLC PPP module to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾