PT-2020-5849
CVE-2021-21285
·
Published
2020-12-22
·
Updated
2026-09-18
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Docker versions prior to 19.03.15
Docker versions prior to 20.10.3
Description:
The issue is related to the incorrect processing of a Docker image manifest, which can cause the dockerd daemon to crash when an intentionally malformed image manifest is pulled. This can be exploited by a remote attacker to cause a denial of service.
Recommendations:
For Docker versions prior to 19.03.15, update to version 19.03.15 or later to prevent the daemon from crashing.
For Docker versions prior to 20.10.3, update to version 20.10.3 or later to prevent the daemon from crashing.
Found an issue in the description? Have something to add? Feel free to write us 👾