PT-2020-5991

CVE-2020-8203

·

Published

2020-04-28

·

Updated

2026-10-08

Description by

CVSS 3.1
7.4
High
MetricsAV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
Name of the Vulnerable Software and Affected Versions Lodash versions prior to 4.17.20 Lodash versions prior to 4.17.19
Description The issue is related to a prototype pollution attack when using the .zipObjectDeep() function in Lodash. This can lead to denial of service or code execution under specific circumstances. The vulnerability allows a malicious user to modify the prototype of Object if the property identifiers are user-supplied. The functions pick, set, setWith, update, updateWith, and zipObjectDeep are affected by this issue.
Recommendations For Lodash versions prior to 4.17.19, update to version 4.17.20 or later to resolve the issue. For Lodash versions prior to 4.17.20, update to version 4.17.20 or later to resolve the issue. As a temporary workaround, consider restricting the use of the .zipObjectDeep() function and other affected functions until a patch is available. Avoid using user-supplied property values or arrays with the affected functions to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-P6MC-M468-83GW
AZL-44964
RHSA-2020:3369
RHSA-2020:3807
RHSA-2020:5179
RHSA-2020:5611
USN-8411-1
Found an issue in the description? Have something to add? Feel free to write us 👾