PT-2020-6035
CVE-2020-28019
·
Published
2020-10-20
·
Updated
2026-10-01
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Exim versions prior to 4.94.2
Description
The issue is related to improper initialization that can lead to recursion-based stack consumption or other consequences. This occurs because the use of certain
getc functions is mishandled when a client uses BDAT instead of DATA. The vulnerability can be exploited by a remote attacker to execute a denial of service (DoS) by sending specially crafted data to the application.Recommendations
For Exim versions prior to 4.94.2, update to version 4.94.2 or later to resolve the issue. As a temporary workaround, consider restricting the use of
BDAT commands to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾