PT-2020-6037

CVE-2020-28011

·

Published

2020-10-20

·

Updated

2026-10-01

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Exim versions prior to 4.94.2
Description The issue is related to a Heap-based Buffer Overflow in the queue run function of the Exim mail transfer agent. This overflow can be triggered via two sender options: -R and -S. The exploitation of this issue may lead to privilege escalation from the Exim user to the root user, potentially allowing an attacker to execute arbitrary code.
Recommendations For Exim versions prior to 4.94.2, update to version 4.94.2 or later to resolve the issue. As a temporary workaround, consider restricting the use of the -R and -S sender options until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALT-PU-2021-1764
ALT-PU-2022-2269
CLEANSTART-2025-DA82799
DLA-2650-1
DSA-4912-1
OPENSUSE-SU-2021:0677-1
OPENSUSE-SU-2021_0677-1
OPENSUSE-SU-2021:0753-1
OPENSUSE-SU-2021:0754-1
OPENSUSE-SU-2024:10746-1
USN-4934-1
USN-4934-2
Found an issue in the description? Have something to add? Feel free to write us 👾