PT-2020-6039

CVE-2020-28015

·

Published

2020-10-20

·

Updated

2026-10-01

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Exim versions prior to 4.94.2
Description The issue is related to insufficient input validation in the Exim message relay agent, which can be exploited to bypass security restrictions and execute arbitrary commands. Local users can alter the behavior of root processes because a recipient address can have a newline character.
Recommendations For Exim versions prior to 4.94.2, update to version 4.94.2 or later to resolve the issue. As a temporary workaround, consider restricting the ability of local users to alter recipient addresses that may contain newline characters.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALT-PU-2021-1764
ALT-PU-2022-2269
CLEANSTART-2025-TZ25317
DLA-2650-1
DSA-4912-1
OPENSUSE-SU-2021:0677-1
OPENSUSE-SU-2021_0677-1
OPENSUSE-SU-2021:0753-1
OPENSUSE-SU-2021:0754-1
OPENSUSE-SU-2024:10746-1
USN-4934-1
USN-4934-2
Found an issue in the description? Have something to add? Feel free to write us 👾