PT-2020-6040
CVE-2020-28012
·
Published
2020-10-20
·
Updated
2026-10-01
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Exim versions prior to 4.94.2
Description
The issue is related to a security mechanism flaw in the Exim message transfer agent. It allows exposure of a file descriptor to an unintended control sphere due to a privileged pipe lacking a close-on-exec flag in the
rda interpret function. This could potentially enable an attacker to elevate privileges.Recommendations
For Exim versions prior to 4.94.2, update to version 4.94.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the
rda interpret function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾