PT-2020-6158
CVE-2020-7789
·
Published
2020-12-11
·
Updated
2020-12-21
Description by
CVSS 2.0
6.8
MediumMetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
node-notifier versions prior to 9.0.0
Description
The issue allows an attacker to run arbitrary commands on Linux machines due to the
options params not being sanitized when being passed an array. This could enable an attacker to execute malicious commands.Recommendations
For versions prior to 9.0.0, update to version 9.0.0 or later to resolve the issue. As a temporary workaround, consider sanitizing the
options params when passing arrays to prevent arbitrary command execution. Found an issue in the description? Have something to add? Feel free to write us 👾