PT-2020-6201
CVE-2020-13362
·
Published
2020-05-28
·
Updated
2024-06-15
Description by
CVSS 3.1
3.2
LowMetricsAV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions
QEMU versions 5.0.0 and earlier
QEMU versions 4.2.0
Description
The issue is related to an out-of-bounds read in the
megasas lookup frame function in hw/scsi/megasas.c. This can be triggered via a crafted reply queue head field from a guest OS user, potentially leading to a denial of service.Recommendations
For QEMU versions 5.0.0 and earlier, update to a version later than 5.0.0 to resolve the issue.
For QEMU version 4.2.0, update to a version later than 4.2.0 to resolve the issue.
As a temporary workaround, consider restricting access to the
megasas lookup frame function in hw/scsi/megasas.c to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾