PT-2020-6264

CVE-2020-25637

·

Published

2020-10-01

·

Updated

2024-06-15

Description by

CVSS 2.0
7.2
High
MetricsAV:L/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions libvirt versions prior to 6.8.0
Description A double free memory issue was found in the libvirt API, responsible for requesting information about network interfaces of a running QEMU domain. This flaw affects the polkit access control driver, allowing clients with limited ACL permissions to potentially crash the libvirt daemon or escalate their privileges. The highest threat from this issue is to data confidentiality and integrity as well as system availability.
Recommendations For versions prior to 6.8.0, update to version 6.8.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the read-write socket to minimize the risk of exploitation. Additionally, limiting ACL permissions for clients connecting to the libvirt daemon can help mitigate the risk until a patch is applied.
Exploitability
Fix
Impacts
Vendors
Affected products
Weakness enumeration
Related identifiers
ALSA-2021:1762
ALT-PU-2020-3005
ALT-PU-2021-1690
ALT-PU-2021-1881
ALT-PU-2021-1965
AZL-6658
CESA-2020_5040
CESA-2021_1762
DLA-2395-1
DLA-3778-1
MGASA-2020-0473
OPENSUSE-SU-2020:1777-1
OPENSUSE-SU-2020_1777-1
OPENSUSE-SU-2020:1778-1
OPENSUSE-SU-2020_1778-1
OPENSUSE-SU-2024:11008-1
RHSA-2020:5040
RHSA-2020_5040
RHSA-2020:5111
RHSA-2021:1762
RHSA-2021_1762
RLSA-2021:1762
SUSE-SU-2020:2969-1
SUSE-SU-2020:2970-1
SUSE-SU-2020:3037-1
SUSE-SU-2020:3038-1
SUSE-SU-2020:3039-1
SUSE-SU-2020:3095-1
SUSE-SU-2020:3143-1
USN-5399-1
Found an issue in the description? Have something to add? Feel free to write us 👾