PT-2020-6468
CVE-2020-10761
·
Published
2020-06-09
·
Updated
2024-06-15
Description by
CVSS 3.1
5.0
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions
QEMU versions prior to 5.0.1
Description
An assertion failure issue was found in the Network Block Device (NBD) Server. This flaw occurs when an nbd-client sends a spec-compliant request that is near the boundary of maximum permitted request length. A remote nbd-client could use this flaw to crash the qemu-nbd server, resulting in a denial of service.
Recommendations
For QEMU versions prior to 5.0.1, update to QEMU 5.0.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the NBD server to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾