PT-2020-6631
CVE-2021-33928
·
Published
2020-09-02
·
Updated
2022-07-05
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
libsolv versions prior to 0.7.17
Description
The issue is related to a buffer overflow vulnerability in the
pool installable function of the src/repo.h component in the Libsolv library. This vulnerability can be exploited by a remote attacker to cause a Denial of Service.Recommendations
For versions prior to 0.7.17, update to version 0.7.17 or later to resolve the issue. As a temporary workaround, consider restricting access to the
pool installable function in the src/repo.h component to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾