PT-2020-6635
CVE-2020-36465
·
Published
2020-04-09
·
Updated
2021-08-25
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
generic-array crate versions prior to 0.13.3
Description
The issue is related to the generic-array crate for Rust, where the arr! macro is used to extend lifetimes, violating soundness. This can lead to memory corruption scenarios, most likely use-after-free. The exploitation of this issue allows a remote attacker to cause a denial of service.
Recommendations
For versions prior to 0.13.3, update to version 0.13.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
arr! macro to minimize the risk of exploitation.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾