PT-2020-6794

CVE-2019-17656

·

Published

2020-10-01

·

Updated

2021-04-19

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions FortiOS versions 6.0.10 and below FortiOS versions 6.2.2 and below FortiProxy versions 1.0.x FortiProxy versions 1.1.x FortiProxy versions 1.2.9 and below FortiProxy versions 2.0.0 and below
Description A Stack-based Buffer Overflow vulnerability in the HTTPD daemon may allow an authenticated remote attacker to crash the service by sending a malformed PUT request to the server. The vulnerability is related to writing data beyond the buffer in memory. Fortinet is not aware of any successful exploitation of this vulnerability that would lead to code execution.
Recommendations For FortiOS versions 6.0.10 and below, update to a version above 6.0.10 to resolve the issue. For FortiOS versions 6.2.2 and below, update to a version above 6.2.2 to resolve the issue. For FortiProxy versions 1.0.x, 1.1.x, 1.2.9 and below, and 2.0.0 and below, consider disabling the HTTPD daemon or restricting access to it until a patch is available. As a temporary workaround, consider restricting the use of the PUT request in the affected API endpoint until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾