PT-2020-6838
CVE-2020-14349
·
Published
2020-06-17
·
Updated
2026-09-18
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 10.14
PostgreSQL versions prior to 11.9
PostgreSQL versions prior to 12.4
Description
The issue is related to the improper sanitization of the
search path during logical replication in PostgreSQL, allowing an authenticated attacker to execute arbitrary SQL commands in the context of the user used for replication. This could potentially lead to privilege escalation and the execution of arbitrary commands.Recommendations
For versions prior to 10.14, update to version 10.14 or later to resolve the issue.
For versions prior to 11.9, update to version 11.9 or later to resolve the issue.
For versions prior to 12.4, update to version 12.4 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾