PT-2020-7587

CVE-2014-0011

·

Published

2014-04-15

·

Updated

2024-06-15

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions TigerVNC versions prior to 1.3.1
Description The issue is related to multiple heap-based buffer overflows in the ZRLE DECODE function, which can be exploited by remote VNC servers. This can lead to a denial of service, causing the vncviewer to crash, and potentially allow the execution of arbitrary code. The issue is tied to the rendering of screen images.
Recommendations For TigerVNC versions prior to 1.3.1, update to version 1.3.1 or later to resolve the issue.
Exploitability
Fix
Impacts
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2015-1777
MGASA-2014-0173
OPENSUSE-SU-2024:10056-1
Found an issue in the description? Have something to add? Feel free to write us 👾