PT-2020-7615

CVE-2014-1947

·

Published

2014-03-12

·

Updated

2020-02-21

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions ImageMagick versions 6.5.4 and earlier
Description A stack-based buffer overflow issue exists in the WritePSDImage function, located in coders/psd.c, which can be triggered by a PSD image containing a large number of layers. This issue may lead to a denial of service (crash) and potentially allow the execution of arbitrary code, involving the L%02ld string.
Recommendations For ImageMagick versions 6.5.4 and earlier, update to a version later than 6.5.4 to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Weakness enumeration
Related identifiers
DSA-2898-1
MGASA-2014-0370
SUSE-SU-2014_0359-1
Found an issue in the description? Have something to add? Feel free to write us 👾