PT-2020-7847

CVE-2015-4411

·

Published

2020-02-20

·

Updated

2020-04-29

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions: mongodb/bson-ruby versions prior to 3.0.4
Description: The issue allows remote attackers to cause a denial of service, specifically worker resource consumption, via a crafted string. This is due to an incomplete fix.
Recommendations: For versions prior to 3.0.4, update to version 3.0.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the Moped::BSON::ObjectId.legal? method until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-QH4W-7PW3-P4RP
Found an issue in the description? Have something to add? Feel free to write us 👾