PT-2020-8034
CVE-2016-3942
·
Published
2020-09-01
·
Updated
2020-09-01
Description by
CVSS 3.1
6.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions:
jsrender versions prior to 0.9.74
Description:
The issue allows for remote code execution when
jsrender is used with server-delivered client-side templates that dynamically embed user input. This can be exploited through specific template syntax, such as the for loop and conditional statements, which can lead to the execution of arbitrary code.Recommendations:
Update to version 0.9.74 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾