PT-2020-8832

CVE-2018-21188

·

Published

2020-04-28

·

Updated

2020-05-05

Description by

CVSS 3.1
6.8
Medium
MetricsAC:L/AV:A/A:H/C:H/I:H/PR:H/S:U/UI:N
Name of the Vulnerable Software and Affected Versions D7800 versions prior to 1.0.1.30 R7500v2 versions prior to 1.0.3.24 R7800 versions prior to 1.0.2.40 R9000 versions prior to 1.0.2.52 WNDR3700v4 versions prior to 1.0.2.92 WNDR4300 versions prior to 1.0.2.94 WNDR4300v2 versions prior to 1.0.0.50 WNDR4500v3 versions prior to 1.0.0.50 WNR2000v5 versions prior to 1.0.0.62
Description The issue is a stack-based buffer overflow that can be exploited by an authenticated user. This is a type of overflow where more data is written to a buffer than it is designed to hold, which can cause the extra data to spill over into adjacent areas of memory, potentially allowing an attacker to execute arbitrary code.
Recommendations For D7800 version prior to 1.0.1.30, update to version 1.0.1.30 or later. For R7500v2 version prior to 1.0.3.24, update to version 1.0.3.24 or later. For R7800 version prior to 1.0.2.40, update to version 1.0.2.40 or later. For R9000 version prior to 1.0.2.52, update to version 1.0.2.52 or later. For WNDR3700v4 version prior to 1.0.2.92, update to version 1.0.2.92 or later. For WNDR4300 version prior to 1.0.2.94, update to version 1.0.2.94 or later. For WNDR4300v2 version prior to 1.0.0.50, update to version 1.0.0.50 or later. For WNDR4500v3 version prior to 1.0.0.50, update to version 1.0.0.50 or later. For WNR2000v5 version prior to 1.0.0.62, update to version 1.0.0.62 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾