PT-2021-10302
CVE-2020-1918
·
Published
2021-03-10
·
Updated
2021-03-15
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions:
HHVM versions prior to 4.56.3
HHVM versions 4.57.0 through 4.80.1
HHVM versions 4.81.0 through 4.93.1
HHVM versions 4.94.0 through 4.98.0
Description:
In-memory file operations, such as using
fopen on a data URI, did not properly restrict negative seeking, allowing for the reading of memory prior to the in-memory buffer.Recommendations:
For HHVM versions prior to 4.56.3, update to version 4.56.3 or later.
For HHVM versions 4.57.0 through 4.80.1, update to version 4.80.2 or later.
For HHVM versions 4.81.0 through 4.93.1, update to version 4.93.2 or later.
For HHVM versions 4.94.0 through 4.98.0, update to a version later than 4.98.0.
Found an issue in the description? Have something to add? Feel free to write us 👾