PT-2021-11286
CVE-2020-26986
·
Published
2020-10-02
·
Updated
2021-02-22
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
JT2Go versions prior to 13.1.0
Teamcenter Visualization versions prior to 13.1.0
Description:
A vulnerability has been identified in the affected applications, where they lack proper validation of user-supplied data when parsing JT files. This could lead to a heap-based buffer overflow, allowing an attacker to execute code in the context of the current process.
Recommendations:
For JT2Go versions prior to 13.1.0, update to version 13.1.0 or later to resolve the issue.
For Teamcenter Visualization versions prior to 13.1.0, update to version 13.1.0 or later to resolve the issue.
As a temporary workaround, consider restricting the parsing of JT files from untrusted sources until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾