PT-2021-11371

CVE-2020-27288

·

Published

2021-01-22

·

Updated

2021-01-29

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: TPEditor versions 1.98 and prior
Description: An untrusted pointer dereference has been identified in the way TPEditor processes project files, allowing an attacker to craft a special project file that may permit arbitrary code execution.
Recommendations: For versions 1.98 and prior, update to a version later than 1.98 to resolve the issue. As a temporary workaround, consider restricting the processing of project files from untrusted sources until a patch is available.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
ZDI-21-080
Found an issue in the description? Have something to add? Feel free to write us 👾