PT-2021-11547
CVE-2020-28487
·
Published
2021-01-22
·
Updated
2021-04-13
Description by
CVSS 3.1
6.8
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L
Name of the Vulnerable Software and Affected Versions:
vis-timeline versions prior to 7.4.4
Description:
The issue allows an attacker with the ability to control the items of a Timeline element to inject additional script code into the generated application. This can be done by exploiting the vulnerability in the vis-timeline package.
Recommendations:
For vis-timeline versions prior to 7.4.4, update to version 7.4.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the Timeline element to minimize the risk of exploitation. Avoid using the vis-timeline package until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾