PT-2021-11990

CVE-2020-36282

·

Published

2021-03-12

·

Updated

2021-12-10

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: JMS Client for RabbitMQ versions 1.x through 1.15.1 JMS Client for RabbitMQ versions 2.x through 2.1.x
Description: The issue is related to unsafe deserialization, which can result in code execution via crafted StreamMessage data.
Recommendations: For JMS Client for RabbitMQ versions 1.x through 1.15.1, update to version 1.15.2 or later. For JMS Client for RabbitMQ versions 2.x through 2.1.x, update to version 2.2.0 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-V525-C3G5-CG9P
Found an issue in the description? Have something to add? Feel free to write us 👾