PT-2021-12814
CVE-2020-8806
·
Published
2021-02-05
·
Updated
2021-02-08
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions:
Zcashd versions prior to 2.1.1-1
Description:
The issue allows attackers to trigger consensus failure and double spending. A valid chain could be incorrectly rejected because timestamp requirements on block headers were not properly enforced.
Recommendations:
For versions prior to 2.1.1-1, update to version 2.1.1-1 or later to resolve the issue. As a temporary workaround, consider implementing additional validation checks on block headers to enforce timestamp requirements until a patch is applied. Restrict access to the consensus mechanism to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾