PT-2021-14385
CVE-2021-21279
·
Published
2021-06-18
·
Updated
2021-06-22
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions:
Contiki-NG versions prior to 4.6
Description:
The issue allows an attacker to perform a denial-of-service attack by triggering an infinite loop in the processing of IPv6 neighbor solicitation (NS) messages. This can effectively shut down the operation of the system due to the cooperative scheduling used for the main parts of Contiki-NG and its communication stack.
Recommendations:
For versions prior to 4.6, apply the patch for this issue out-of-band as a workaround.
Update to Contiki-NG version 4.6 to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾